Error running script/generate

Eric Marthinsen's Avatar

Eric Marthinsen

01 Feb, 2010 01:31 PM

Hello. I'm trying to upgrade and when I run the generator, I get the following error. Any ideas how to get around this? What is it event trying to test that it would fail in such a way?

$ sudo ruby script/generate hoptoad --api-key REMOVED
Password:
/Users/ericmarthinsen/.gem/ruby/1.8/gems/rails-2.1.1/lib/rails_generator/lookup.rb:211:Warning: Gem::SourceIndex#search support for Regexp patterns is deprecated, use #find_name
      exists  lib/tasks
      create  lib/tasks/hoptoad_notifier_tasks.rake
      insert  
Dir[File.join(File.dirname(__FILE__), '..', 'vendor', 'gems', 'hoptoad_notifier-*')].each do |vendored_notifier|
  $: << File.join(vendored_notifier, 'lib')
end

require 'hoptoad_notifier/capistrano'
 appended to config/deploy.rb
      create  config/initializers/hoptoad.rb
        rake  rake hoptoad:test
(in /Users/ericmarthinsen/Sites/daily_grommet)
DEPRECATION WARNING: config.action_view.cache_template_extensions option has been deprecated and has no affect. Please remove it from your config files.  See http://www.rubyonrails.org/deprecation for details. (called from send at /Users/ericmarthinsen/.gem/ruby/1.8/gems/rails-2.1.1/lib/initializer.rb:464)
DEPRECATION WARNING: Inflector is deprecated! Use ActiveSupport::Inflector instead.  See http://www.rubyonrails.org/deprecation for details. (called from /Users/ericmarthinsen/Sites/daily_grommet/vendor/plugins/active_merchant/lib/active_merchant/billing/integrations.rb:13)
** [Hoptoad] Notifier 2.1.3 ready to catch errors
Configuration:
             notifier_url: "http://hoptoadapp.com"
                     port: 80
         environment_name: "development"
        http_read_timeout: 5
         notifier_version: "2.1.3"
               proxy_pass: nil
                   ignore: ["ActiveRecord::RecordNotFound", "ActionController::Rou
           params_filters: ["password", "password_confirmation"]
        ignore_by_filters: []
        backtrace_filters: [#<Proc:0x00000001023af630@/Users/ericmarthinsen/Sites/
             project_root: "/Users/ericmarthinsen/Sites/daily_grommet"
                   secure: false
        ignore_user_agent: []
 development_environments: []
       development_lookup: true
                 protocol: "http"
                  api_key: "REMOVED"
            notifier_name: "Hoptoad Notifier"
               proxy_user: nil
               proxy_port: nil
               proxy_host: nil
        http_open_timeout: 2
                     host: "hoptoadapp.com"
Setting up the Controller.
Processing request.
rake aborted!
Access denied for user 'root'@'localhost' (using password: NO)

(See full trace by running task with --trace)
        rake  hoptoad:test failed. Rolling back
          rm  config/initializers/hoptoad.rb
      remove  
Dir[File.join(File.dirname(__FILE__), '..', 'vendor', 'gems', 'hoptoad_notifier-*')].each do |vendored_notifier|
  $: << File.join(vendored_notifier, 'lib')
end

require 'hoptoad_notifier/capistrano'
 removed from config/deploy.rb
          rm  lib/tasks/hoptoad_notifier_tasks.rake
    notempty  lib/tasks
    notempty  lib
  1. 2 Posted by Jon Yurek on 01 Feb, 2010 07:10 PM

    Jon Yurek's Avatar

    Hello,

    First, unless the root user has created the project, you don't need "sudo" when running the script/generate command.

    Second, the error that you're getting means that the environment that hoptoad is setting up in order to check its configuration is trying to connect to a database that doesn't exist. The rake hoptoad:test task (which gets run by script/generate hoptoad uses whatever environment you're in at the time, so it's probable that you're missing your development database. Please try rake db:create and then running script/generate hoptoad again.

  2. 3 Posted by Eric Marthinsen on 02 Feb, 2010 02:55 PM

    Eric Marthinsen's Avatar

    Thanks!

  3. Chad Pytel closed this discussion on 02 Feb, 2010 06:23 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac